Fresh Install Failing due to PostgreSQL v 9.1 not supporting ALTER TABLE IF EXISTS

Hi Everyone,

I’m trying to perform a fresh install of OpenLMIS 2.0 for demo purposes. I created this issue in GitHub which shows incompatability between the PostgreSQL v. 9.1 and one of the migration scripts. I looked into upgrading the FlyWay version to support PostgreSQL 9.3, but it would be a big job. I also noticed that a lot of the migration scripts are in an archive folder, and the culprit is definitely in that folder as well. Do I need to execute those migrations? If not, is there a command I can provide to gradle that will skip everything in the “archive” directory?

The end goal is to be able to setup a local demo of OpenLMIS 2.0 for development and testing purposes. Is there an easier way? I attached the start of my install script for reference.

Sincerely,

Craig

Dev_OpenLMIS2_Install_Script.sh (1.7 KB)

Hi Craig,

Postgres 9.2 is the minimum required. I am running 9.4.4 (Windows) and was able to compile and run a fresh 2.0 branch pull. I believe IF EXISTS was added to 9.2.

Was talking this over with Chongsun and he noted that the gradle build file specifies 9.1 – we are probably out of date in that respect. Can you try 9.2 or higher and see if that resolves the issue?

Thanks - Rich

···

Hi Everyone,

I’m trying to perform a fresh install of OpenLMIS 2.0 for demo purposes. I created this issue in GitHub which shows incompatability between the PostgreSQL v. 9.1 and one of the migration scripts. I looked into upgrading the FlyWay version to support PostgreSQL 9.3, but it would be a big job. I also noticed that a lot of the migration scripts are in
an archive folder
, and the culprit is definitely in that folder as well. Do I need to execute those migrations? If not, is there a command I can provide to gradle that will skip everything in the “archive” directory?

The end goal is to be able to setup a local demo of OpenLMIS 2.0 for development and testing purposes. Is there an easier way? I attached the start of my install script for reference.

Sincerely,

Craig

You received this message because you are subscribed to the Google Groups “OpenLMIS Dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openlmis-dev+unsubscribe@googlegroups.com.

To post to this group, send email to
openlmis-dev@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/openlmis-dev/2b867dd2-e7a0-4b23-8635-7eed33bae1cd%40googlegroups.com
.

For more options, visit https://groups.google.com/d/optout.

Small update: the gradle tasks and readme were updated to specify Postgres 9.2.

···

On Tuesday, December 22, 2015 at 12:07:35 PM UTC-8, Rich Magnuson wrote:

Hi Craig,

Postgres 9.2 is the minimum required. I am running 9.4.4 (Windows) and was able to compile and run a fresh 2.0 branch pull. I believe IF EXISTS was added to 9.2.

Was talking this over with Chongsun and he noted that the gradle build file specifies 9.1 – we are probably out of date in that respect. Can you try 9.2 or higher and see if that resolves the issue?

Thanks - Rich

From: openlmis-dev@googlegroups.com [mailto:openlmis-dev@googlegroups.com] On Behalf Of Craig A

Sent: Tuesday, December 22, 2015 11:21 AM

To: OpenLMIS Dev openlmis-dev@googlegroups.com

Subject: [openlmis-dev] Fresh Install Failing due to PostgreSQL v 9.1 not supporting ALTER TABLE IF EXISTS

Hi Everyone,

I’m trying to perform a fresh install of OpenLMIS 2.0 for demo purposes. I created this issue in GitHub which shows incompatability between the PostgreSQL v. 9.1 and one of the migration scripts. I looked into upgrading the FlyWay version to support PostgreSQL 9.3, but it would be a big job. I also noticed that a lot of the migration scripts are in
an archive folder
, and the culprit is definitely in that folder as well. Do I need to execute those migrations? If not, is there a command I can provide to gradle that will skip everything in the “archive” directory?

The end goal is to be able to setup a local demo of OpenLMIS 2.0 for development and testing purposes. Is there an easier way? I attached the start of my install script for reference.

Sincerely,

Craig