Installation not complete due to http request failed http://172.18.0.18:8080 no route to host

Installation not complete due to http request failed http://172.18.0.18:8080 no route to host

when give command docker-compose up
Installation stops at consul_1 with above mentioned error

Please help

Hello,

I have a couple of questions:

  1. Are you trying to run ref-distro, right?
  2. Do you have your IP address set as a value of BASE_URL and VIRTUAL_HOST? Could you show me how exactly settings.env file looks for you?

Kind regards,
Klaudia

Yes I have followed steps in quick setup guide at https://openlmis.atlassian.net/wiki/spaces/OP/pages/115681666/OpenLMIS+Technical+Setup+Guide#OpenLMISTechnicalSetupGuide-ServerEnvironments under Installation section

When I run docker-compose up, I can see these errors
I am first trying to run it on my local machine and here is my settings.env, where I have changed IP to the IP of my machine

Nginx, Consul and other common settings

The base url of the OpenLMIS distribution. Will be used for communication between services.

In case of generated links pointing to the distribution, the PUBLIC_URL should be used instead.

BASE_URL=http://10.197.189.224

The virtual host for the nginx server - nginx will make services available under this host.

VIRTUAL_HOST=10.197.189.224

The public url of the OpenLMIS distribution. Should be used in generated links pointing to the distribution.

If this variable is not set, the BASE_URL will be used for the generated links.

PUBLIC_URL=http://10.197.189.224

Rest of the things are untouched, same as settings-sample.env

If I run docker-compose up -d, I don’t see any of these errors but in that case when I go to http://10.197.189.224, it stays starting LMIS and then a webpage with black background with no sign in form

Your help shall be highly appreciable. We are a non profit organization Red Cross and need this package for our warehouses across the districts
My settings.env

I would recommend using docker-compose up command, without -d then you will see logs. I always wait for FTP logs, and then try to log into the application.

Kind regards,
Klaudia

Dear Ma’am

Sorry for responding late somehow I missed your email

My settings.env is

In case of generated links pointing to the distribution, the PUBLIC_URL should be used instead.

BASE_URL=http://192.168.43.219

The virtual host for the nginx server - nginx will make services available under this host.

VIRTUAL_HOST=192.168.43.219

The public url of the OpenLMIS distribution. Should be used in generated links pointing to the distribution.

If this variable is not set, the BASE_URL will be used for the generated links.

PUBLIC_URL=http://192.168.43.219

Hello Shikha - Were you able to try @Klaudia_Palkowska’s suggestion regarding spinning up the instance of OpenLMIS using the docker-compose up command? Likewise, it is important to give your docker machine enough hardware to run OpenLMIS. I think the realistic setup would be to dedicate 8GB of RAM and at least 2 CPU’s to docker and then wait for the FTP logs to appear in the terminal output.

Please let us know if you are able to make any progress using that setup.

Thanks,
-Wes