Trouble starting OpenLMIS-Blue // HELP!

y’all~

I can’t get blue to stand up, and am looking for thoughts about how to debug this

The images are the newest

The docker images

I have added the .env file

Consul is running and accessiable at 192.168.99.100:8500 — and supposedly all the services ‘are running’

If I hit any URL endpoint I get a 503 error (ie GET http://192.168.99.100//auth/ returns a 503)

Chungsong and I tried working through this, but no luck…. does anyone have additional thoughts?

My next step was to install the docker beta (because its working for others) but that shouldn’t be a requirement ~ right?

(yes, this is cross posted in the slack channel)

– nick –

···

Nick Reid | nick.reid@villagereach.org

Friendly Neighborhood Spiderman, Information Systems Group

VillageReach** *** Starting at the Last Mile
*2900 Eastlake Ave. E, Suite 230, Seattle, WA 98102, USA

CELL: +1.510.410.0020

SKYPE: nickdotreid

www.villagereach.org

Hi Nick,

The services are configured to use “localhost” as virtual host:

auth:

image: openlmis/auth

env_file: .env

environment:

  - VIRTUAL_HOST=**localhost**
  • VIRTUAL_LOCATION=auth

I ran blue with:

docker-compose -f docker-compose.discovery.yml up -d

Then I accessed http://localhost/auth/

It worked normally.

Then I accessed http://10.203.22.128/auth/ (it’s my lan ip)

I got 503, same as you did.

I think the reason you can access consul with your lan ip but not any of the services is that consul’s 8500 port is exposed to the host. But the services are taking requests through nginx, and nginx only knows the virtual_host that was given.

···

On Tue, Sep 27, 2016 at 4:26 AM, Nick Reid nick.reid@villagereach.org wrote:

y’all~

I can’t get blue to stand up, and am looking for thoughts about how to debug this

The images are the newest

The docker images

I have added the .env file

Consul is running and accessiable at 192.168.99.100:8500 — and supposedly all the services ‘are running’

If I hit any URL endpoint I get a 503 error (ie GET http://192.168.99.100//auth/ returns a 503)

Chungsong and I tried working through this, but no luck…. does anyone have additional thoughts?

My next step was to install the docker beta (because its working for others) but that shouldn’t be a requirement ~ right?

(yes, this is cross posted in the slack channel)

– nick –

Nick Reid | nick.reid@villagereach.org

Friendly Neighborhood Spiderman, Information Systems Group

VillageReach** *** Starting at the Last Mile
*2900 Eastlake Ave. E, Suite 230, Seattle, WA 98102, USA

CELL: +1.510.410.0020

SKYPE: nickdotreid

www.villagereach.org

You received this message because you are subscribed to the Google Groups “OpenLMIS Dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openlmis-dev+unsubscribe@googlegroups.com.

To post to this group, send email to openlmis-dev@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/openlmis-dev/BLUPR02MB325C543D17BA8142F041FF594CD0%40BLUPR02MB325.namprd02.prod.outlook.com.

For more options, visit https://groups.google.com/d/optout.

ah that makes sense — I guess I should use the docker beta … like everyone else (I assume)

I’ll get back to you in that doesn’t work.

···

Nick Reid | nick.reid@villagereach.org

Friendly Neighborhood Spiderman, Information Systems Group

VillageReach** *** Starting at the Last Mile
*2900 Eastlake Ave. E, Suite 230, Seattle, WA 98102, USA

CELL: +1.510.410.0020

SKYPE: nickdotreid

www.villagereach.org


From: Pengfei Cui pfcui@thoughtworks.com

Sent: Monday, September 26, 2016 8:34:23 PM

To: Nick Reid

Cc: openlmis-dev@googlegroups.com

Subject: Re: [openlmis-dev] Trouble starting OpenLMIS-Blue // HELP!

Hi Nick,

The services are configured to use “localhost” as virtual host:

auth:

image: openlmis/auth

env_file: .env

environment:

  - VIRTUAL_HOST=**localhost**
  • VIRTUAL_LOCATION=auth

I ran blue with:

docker-compose -f docker-compose.discovery.yml up -d

Then I accessed http://localhost/auth/

It worked normally.

Then I accessed http://10.203.22.128/auth/ (it’s my lan ip)

I got 503, same as you did.

I think the reason you can access consul with your lan ip but not any of the services is that consul’s 8500 port is exposed to the host. But the services are taking requests through nginx, and nginx only knows the virtual_host that was given.

On Tue, Sep 27, 2016 at 4:26 AM, Nick Reid
nick.reid@villagereach.org wrote:

y’all~

I can’t get blue to stand up, and am looking for thoughts about how to debug this

The images are the newest

The docker images

I have added the .env file

Consul is running and accessiable at
192.168.99.100:8500
— and supposedly all the services ‘are running’

If I hit any URL endpoint I get a 503 error (ie GET
http://192.168.99.100//auth/
returns a 503)

Chungsong and I tried working through this, but no luck…. does anyone have additional thoughts?

My next step was to install the docker beta (because its working for others) but that shouldn’t be a requirement ~ right?

(yes, this is cross posted in the slack channel)

– nick –

Nick Reid | nick.reid@villagereach.org

Friendly Neighborhood Spiderman, Information Systems Group

VillageReach** *** Starting at the Last Mile
*2900 Eastlake Ave. E, Suite 230, Seattle, WA 98102, USA

CELL: +1.510.410.0020

SKYPE: nickdotreid

www.villagereach.org

You received this message because you are subscribed to the Google Groups “OpenLMIS Dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to openlmis-dev+unsubscribe@googlegroups.com.

To post to this group, send email to
openlmis-dev@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/openlmis-dev/BLUPR02MB325C543D17BA8142F041FF594CD0%40BLUPR02MB325.namprd02.prod.outlook.com
.

For more options, visit
https://groups.google.com/d/optout
.

Hi Nick,

The services are configured to use “localhost” as virtual host:

auth:

image: openlmis/auth

env_file: .env

environment:

  - VIRTUAL_HOST=**localhost**
  • VIRTUAL_LOCATION=auth

I ran blue with:

docker-compose -f docker-compose.discovery.yml up -d

Then I accessed http://localhost/auth/

It worked normally.

Then I accessed http://10.203.22.128/auth/ (it’s my lan ip)

I got 503, same as you did.

I think the reason you can access consul with your lan ip but not any of the services is that consul’s 8500 port is exposed to the host. But the services are taking requests through nginx, and nginx only knows the virtual_host that was given.

I don’t think you need to install the beta version. Just use localhsot instead of your lan ip, I think it should work.

···

On Tuesday, September 27, 2016 at 4:26:27 AM UTC+8, Nick Reid wrote:

y’all~

I can’t get blue to stand up, and am looking for thoughts about how to debug this

The images are the newest

The docker images

I have added the .env file

Consul is running and accessiable at 192.168.99.100:8500 — and supposedly all the services ‘are running’

If I hit any URL endpoint I get a 503 error (ie GET http://192.168.99.100//auth/ returns a 503)

Chungsong and I tried working through this, but no luck…. does anyone have additional thoughts?

My next step was to install the docker beta (because its working for others) but that shouldn’t be a requirement ~ right?

(yes, this is cross posted in the slack channel)

– nick –

Nick Reid | nick...@villagereach.org

Friendly Neighborhood Spiderman, Information Systems Group

VillageReach** *** Starting at the Last Mile
*2900 Eastlake Ave. E, Suite 230, Seattle, WA 98102, USA

CELL: +1.510.410.0020

SKYPE: nickdotreid

www.villagereach.org